Publicado el


Descripción Actualiza la información de un widget
URL https://api.codeeta.com/widgets/update
Método POST
Nivel de servicio Designer y superiores
Parámetros
api_token
widget_id
name
is_active
language
currency
payment_gateway
paypal_account
Resultado
400 – “Bad request”
400 – “language param must be one of these options: es-ES, en-GB, pt-BR, de-DE, it-IT, fr-FR”
400 – “name param must be 0 to 50 characters long”
400 – “currency param must be one of these options: EUR, USD, GBP, BRL, MXN, CAD, CHF, SEK, NOK, PLN, HUF, CZK, ILS, AUD, NZD, DKK”
400 – “payment_gateway param must be ‘PAYPAL_STANDARD”
400 – “widget_type widgets does not support payment gateways”
401 – “Bad credentials”
403 – “You are not authorised to perform this action”
200 – “Widget successfully updated”